Modified Deprecated

Aus Fishnet Wiki
Zur Navigation springen Zur Suche springen

Alle Fehlermeldungen in denen das Wort deprecated (zu deutsch: veraltet) vorkommt, weisen darauf hin, das ein Code veraltet ist. Das führt in der Regel noch nicht dazu, das der Shop nicht mehr funktioniert, ist aber eine deutliche Warnung, das es in Zukunft dazu kommen kann. Hintergrund: Die Programmiersprache PHP wird laufend weiterentwickelt, neue Befehle kommen hinzu und alte verschwinden. Diese alten Befehle werden erst als deprecated gekennzeichnet und in einem späteren Update entfernt.

Lösung:

sehr kurzfristig: Fehlermeldung unterdrücken, zB. durch Umbenennen der Datei "export/error_reporting.all" in "_error_reporting.admin"

kurzfristig: Hoster bitten, die PHP Version (die er vielleicht hochgesetzt hat), wieder runterzusetzen.

mittelfristig: Shop updaten auf die neueste Version.

Bekommen Sie eine deprecated Meldung, nachdem Sie ein Modul eingebaut haben, scheint der Code des Moduls veraltet zu sein. In diesem Fall sollten Sie das Modul wieder ausbauen und eine neuere Version suchen.